How To Guide Z4 roof motor relocation to boot

Rikard

Newbie
Joined
Jun 23, 2021
Messages
1
Newbie here who just want to thank the thread starter and all other contributors!

My motor was beyond repair so I ordered a non-OEM from Amazon (150 EUR) which was fitted yesterday and holy cow, it works.

My first ever car DIY on our new family member, black Z4 3.0 2003.

Biggest challenge, besides learning a new English vocabulary for bolts, tools etc., was to separate the housing. Was just about to turn into Hulk-mode when I got the idea to dismount a tounge-and-groove plie where one piece created the perfect angle to pry it apart while supported by the wall of the motor housing space.

BMW work-shop quoted around 1200 EUR to do it with unknown lead time as there were 600 outstanding orders for a new OEM motor.

Again, thank you all!
 
Last edited:

OhioZ4

Newbie
American Zeds
Joined
Jun 15, 2021
Messages
9
Location
Ohio USA
Model of Z
E85 2.5i Sport
I havent ran into this well known problem yet but I know when I do , and Im sure I will , Ill be looking at this topic . Thanks for the writeup and pics , they are sure to help .
 

myrddin

Newbie
Joined
Mar 23, 2021
Messages
7
Any of you guys ever think about drilling the drain hole out to like an inch and adding a larger drain tube? I relocated my pump but still have issues with water collecting in the tubs.
 

colb

Zorg Guru (IV)
British Zeds
Joined
Nov 25, 2012
Messages
1,528
Location
Newport, South Wales,UK
Model of Z
Z3 M43 1.8 (1999) and Z4 E85 2.5 (2003)
The drain tubes should be big enough, have you taken the rubber one way valve caps off the sill end, thats the best thing you can do to allow free flow. Still need to rod them to ensure they keep clear once or twice a year.
 

myrddin

Newbie
Joined
Mar 23, 2021
Messages
7
I have removed the caps. I will try the rod to see if I can free them up. I honestly think if they were bigger they wouldn’t get clogged at all. Design flaw.
 

Mswchef

Newbie
Joined
Aug 12, 2021
Messages
1
Hello all....today i started the grand job of relocating the seized roof motor. On my 2005 Z4.ive come stuck with fitting the pump to the motor...when i finally got the top part off these parts fell out...i worked out the spring coil, the 2 pins but i dont have a 3rd pin and where do the 2 curved metal pieces go...?

The motor works but it is not engaging the roof mechanism as just its not connecting to the rod in the pump ?

Any ideas will be gratefully accepted thanks in advance. Mark
 

Attachments

Top